48 lines
1.3 KiB
Plaintext
Executable File
48 lines
1.3 KiB
Plaintext
Executable File
maintainer="fossdd <fossdd@pwned.life>"
|
|
pkgname=anubis
|
|
pkgver=1.18.0
|
|
pkgrel=0
|
|
pkgdesc="Block AI scrapers using a sha256 proof-of-work challenge"
|
|
url="https://github.com/TecharoHQ/anubis"
|
|
arch="all"
|
|
license="MIT"
|
|
makedepends="go npm bash zstd brotli"
|
|
pkgusers="anubis"
|
|
pkggroups="anubis"
|
|
install="$pkgname.pre-install"
|
|
subpackages="$pkgname-doc
|
|
$pkgname-openrc
|
|
"
|
|
source="$pkgname-$pkgver.tar.gz::https://github.com/TecharoHQ/anubis/archive/refs/tags/v$pkgver.tar.gz
|
|
$pkgname.initd
|
|
"
|
|
options="net !check" # check: no test suite
|
|
|
|
# secfixes:
|
|
# 1.15.2-r0:
|
|
# - CVE-2025-24369
|
|
|
|
preparre() {
|
|
default_prepare
|
|
|
|
make deps
|
|
}
|
|
|
|
build() {
|
|
make assets
|
|
make prebaked-build
|
|
}
|
|
|
|
package() {
|
|
install -Dm755 var/anubis -t "$pkgdir"/usr/bin/
|
|
install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
|
|
|
|
install -D -m 755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
|
|
install -d -m 644 "$pkgdir"/etc/$pkgname
|
|
install -d -m 755 -o $pkgusers -g $pkggroups "$pkgdir"/var/log/$pkgname
|
|
}
|
|
|
|
sha512sums="
|
|
6b85f0fc5722b14f4d9ca519705a879eed5beb87e67411e741b5f5a7e909ee20c5aa8c4350764d1e6408484a4cbb3b544590bc2c45d6be972b559e3f13fe0c75 anubis-1.18.0.tar.gz
|
|
e4909951c183bd4a7ff932fca5591a0d9aebd7aa569384a6c807d3ef9cfc00df2e0d7c872a2fa7ddbcfd60ba49f35140236ccb8d4c756ae9f81800fad22fcb21 anubis.initd
|
|
" |